7.9.3. Tools

7.9.3.1. Basic information on operation
7.9.3.2. Default
7.9.3.2.1. Insert sketch" dialog box (*.dbs, *.skt or *.hsk files)
7.9.3.2.2. DXF import " dialog box (*.dxf file)
7.9.3.3. Delete
7.9.3.3.1. Delete from history and sketch
7.9.3.3.1.1. Delete Selected Step
7.9.3.3.1.2. Delete the selected step with its dependent elements Delete
7.9.3.3.1.3. Delete the last step
7.9.3.3.2. Delete using the entry in the "Sketch History" docking window
7.9.3.3.2.1. Delete Element
7.9.3.3.2.2. Conditionally Delete Element
7.9.3.3.2.3. Delete all elements except CP
7.9.3.4. Shapes -> Points
7.9.3.4.1. Connection points for assembly construction
7.9.3.4.1.1. Connection points in general
7.9.3.4.1.2. Naming convention for connection points and insertion lines
7.9.3.4.1.3. Alignment of connection points
7.9.3.4.1.4. Connection points on miters
7.9.3.4.1.5. Connection points on screw connection elements
7.9.3.4.1.6. Create insertion line
7.9.3.4.2. Connection points as published elements for automatic placement in CAD
7.9.3.5. Shapes -> Lines
7.9.3.6. Forms -> Special
7.9.3.6.1. Insert rectangle
7.9.3.6.2. Insert rectangle over center point
7.9.3.6.3. Insert hexagon
7.9.3.6.4. Insert N-corner
7.9.3.6.5. Insert polygon
7.9.3.7. Shapes -> Circles
7.9.3.7.1. Circle with center point and radius/point
7.9.3.7.2. Circle through 3 points
7.9.3.7.3. Circle through center point and tangential element
7.9.3.7.4. Create circle tangent to 2 elements (circle/line/arc)
7.9.3.7.5. Circle tangential to 3 elements (circle/line/arc)
7.9.3.7.6. Circle tangent to 3 circles
7.9.3.7.7. Insert slotted hole
7.9.3.8. Shapes -> Arcs
7.9.3.9. Shapes -> Ellipses and ellipse segments
7.9.3.10. Attributes
7.9.3.11. Modify -> Transform
7.9.3.12. Modify -> Crop (Part 1)
7.9.3.13. Modify -> Crop (part 2)
7.9.3.14. Modify -> Thread
7.9.3.14.1. Cylindrical thread by length
7.9.3.14.2. Conical thread by lengths
7.9.3.15. Tools in drawing mode
7.9.3.15.1. Text
7.9.3.15.2. Attributes
7.9.3.15.3. Attributes -> Dimensioning mode
7.9.3.15.4. Attributes -> Insert hat ching
7.9.3.15.5. Attributes -> Polyline
7.9.3.15.6. Ellipses and ellipse segments

As of V12 tools are displayed in groups by default.

Example: Group "Lines" opened

Example: Group "Lines" opened

Clicking with the secondary mouse key at any place in a toolbar will open a menu to turn on and off the toolbars:

  • Default

  • Delete

  • Attributes

  • Quick settings

  • Shapes

  • Modify

The following illustration shows the toolbar names and also the group names as they are used when the Group tools setting option is deactivated.

Display of functions with setting option "Group tools [Group tools] " activated

Display of functions with setting option "Group tools [Group tools] " activated

The Group tools function is switched on by default. You can find the option to switch it on and off in the PARTdesigner under Tools [Extras] menu -> Settings [Preferences...]... -> Sketcher (hist.) [Sketcher (feat.)].

The following figure shows the toolbars with names without grouping:

  • Default

  • Delete

  • Special

  • Lines

  • Quick settings

  • Trim

  • Points

  • Circles

  • Arcs

  • Transform

  • Attributes

  • Threads

  • Ellipses (deactivated by default)

Display of functions with setting option "Group tools [Group tools] " deactivated

Display of functions with setting option "Group tools [Group tools] " deactivated